Facebook login issue in unity 2018.2.2f1.

I can’t login with Facebook in the new unity version 2018.2.2f1.

The same code which worked in unity 2017.3 version is no longer working in 2018.2.2f1 and I don’t know what to do.

I’ve also updated the Facebook SDK to the latest v7.13.0 but no luck there.

I’m getting this error in the debug logs.

KeyNotFoundException: The given key was not present in the dictionary.
System.Collections.Generic.Dictionary`2[TKey,TValue].get_Item (TKey key) (at :0)
Facebook.Unity.Editor.Dialogs.MockLoginDialog+<>c__DisplayClass4_0.b__1 (Facebook.Unity.IGraphResult permResult) (at <73a87e4086d24d19bbdbcee40c7995d3>:0)
Facebook.Unity.AsyncRequestString+d__9.MoveNext () (at <73a87e4086d24d19bbdbcee40c7995d3>:0)
UnityEngine.SetupCoroutine.InvokeMoveNext (System.Collections.IEnumerator enumerator, System.IntPtr returnValueAddress) (at /Users/builduser/buildslave/unity/build/Runtime/Export/Coroutines.cs:17)

Also I’ve tried using the example code provided with the Facebook SDK and they also gave the same error.

My facebook login code looks like this.

FB.LogInWithReadPermissions(new List() { “public_profile”, “email”, “user_friends” }, AuthCallback);

AuthCallback is never getting called and I’m getting the above mentioned error.

How to resolve this issue?

@hindusingh Have you got the solution for it?