Facebook.Unity.Gameroom.dll was not registered

Whenever I launch Unity, I get the following error:

Assertion failed: Extension Library/FacebookSDK/Facebook.Unity.Gameroom.dll was not registered, that means it relies on default UnityExtensions settings, please register extension and apply necessary settings for it in the callback.

I tried deleting the Library folder but the problem is still there and the file Facebook.Unity.Gameroom.dll also exists.

Also when I try to build for WebGL, 3 more errors are shown and build fails. The first one is as follows:

ArgumentException: The Assembly Facebook.Unity is referenced by Facebook.Unity.Gameroom ('Library/FacebookSDK/Facebook.Unity.Gameroom.dll'). But the dll is not allowed to be included or could not be found.
UnityEditor.AssemblyHelper.AddReferencedAssembliesRecurse (System.String assemblyPath, System.Collections.Generic.List`1 alreadyFoundAssemblies, System.String[] allAssemblyPaths, System.String[] foldersToSearch, System.Collections.Generic.Dictionary`2 cache, BuildTarget target) (at C:/buildslave/unity/build/Editor/Mono/AssemblyHelper.cs:142)
UnityEditor.AssemblyHelper.FindAssembliesReferencedBy (System.String[] paths, System.String[] foldersToSearch, BuildTarget target) (at C:/buildslave/unity/build/Editor/Mono/AssemblyHelper.cs:179)
UnityEditor.HostView:OnGUI()

How can I solve this?

I’m having the same problem. I reinstalled Unity without Gameroom support, but I still get this error in Cloud Build:

ArgumentException: The Assembly Facebook.Unity is referenced by Facebook.Unity.Gameroom (‘Library/FacebookSDK/Facebook.Unity.Gameroom.dll’). But the dll is not allowed to be included or could not be found.

Anyone? I am having this issue too :frowning:

Note that as a simple workaround for the problem I created a copy of the cloud build config, and it worked. It’s an easy way to make sure there is no leftovers from previous build.

  1. in “[UnityInstallationDir]/Editor/Data/PlaybackEngines” rename the “facebook” folder to something else, so that it will not be found by Unity upon start.

  2. In your Project sourcecode make sure to put every line of “using Facebook.Unity” in compile tags, like this

List item

#if UNITY_FACEBOOK
       	using Facebook.Unity;
#endif

Hope this helps (it did in my case).
cheers, ponx

It’s a cache issue:

  1. Close Unity and your script editor.
  2. Go into your project folder.
  3. Delete the folder “Temp”.

Now it should Build & Run as expected.

@NafisKhan I was getting the same error don’t know if this will helps anyone out there…
_

  1. If you upgraded to the newest SDK for facebook from the player setttings revert back to the version that you currently had after you downloaded the FaceBook compiler for Unity.
  2. You can also check what SDK versions you have by going to this folder: UnityInstallationDir]/Editor/Data/PlaybackEngines/Facebook/SDK (You may find this version 7.9.4 if that is the only SDK in there select it.)
  3. you can go to this site:Downloads - Unity SDK - Documentation - Meta for Developers
    to download the latest FB SDK for Unity.
  4. Lastly, I changed my target platform by pressing Crtl+Shift+B and under the Facebook build settings you can change it from GameRoom(Windows) to WebGL.
    _
    That’s it! should work…