Failed to fetch the following dependencies: org.jetbrains.kotlin:kotlin-bom:1.8.10

I am using Unity 2022.3.10f1 and IronSource_IntegrationManager_v7.5.1 (yes, i am using unity LevelPlay for ads). When I try to resolve, error message appear. Message at console "Failed to fetch the following dependencies: org.jetbrains.kotlin:kotlin- bom:1.8.10".

I tried install manually jdk, sdk, ndk, gradle here, installed GooglePlayGames plugin, messed with custom gradle files. But all I see is popup “failed” for the next 3 days of resolving again and again.

Here is full error at console

Resolution failed

Failed to fetch the following dependencies:
org.jetbrains.kotlin:kotlin-bom:1.8.10


0x00007ff6081c282d (Unity) StackWalker::GetCurrentCallstack
0x00007ff6081c77d9 (Unity) StackWalker::ShowCallstack
0x00007ff609197831 (Unity) GetStacktrace 0x00007ff609855d52 (Unity)
DebugStringToFile 0x00007ff6070f6db6 (Unity)
DebugLogHandler_CUSTOM_Internal_Log 0x0000027f44b2eaa3 (Mono JIT Code)
(wrapper managed-to-native) UnityEngine.DebugLogHandler:Internal_Log
(UnityEngine.LogType,UnityEngine.LogOption,string,UnityEngine.Object)
0x0000027f44b2e71b (Mono JIT Code)
UnityEngine.DebugLogHandler:LogFormat
(UnityEngine.LogType,UnityEngine.Object,string,object[])
0x0000027f44b2e460 (Mono JIT Code) UnityEngine.Logger:Log
(UnityEngine.LogType,object) 0x0000027fb45c5d45 (Mono JIT Code)
UnityEngine.Debug:LogError (object) 0x0000027f44bc57fb (Mono JIT Code)
Google.Logger:Log (string,Google.LogLevel) 0x0000027f4716163f (Mono
JIT Code) GooglePlayServices.PlayServicesResolver:Log
(string,Google.LogLevel) 0x0000027fb45c5ceb (Mono JIT Code)
GooglePlayServices.GradleResolver:LogMissingDependenciesError
(System.Collections.Generic.List`1<string>) 0x0000027fb45c580b (Mono
JIT Code)
GooglePlayServices.GradleResolver/<DoResolutionUnsafe>c__AnonStorey14:<>m__1F
(System.Collections.Generic.List`1<Google.JarResolver.Dependency>)
0x0000027fb45c4a71 (Mono JIT Code)
GooglePlayServices.GradleResolver/<GradleResolution>c__AnonStoreyF:<>m__16
() 0x0000027fb45c4064 (Mono JIT Code)
GooglePlayServices.GradleResolver/<GradleResolution>c__AnonStoreyF:<>m__24
() 0x0000027fa949f499 (Mono JIT Code)
GooglePlayServices.GradleResolver/<ProcessAars>c__AnonStorey17:<>m__21
() 0x0000027f44bcb81d (Mono JIT Code)
Google.RunOnMainThread:ExecutePollingJobs () 0x0000027f44bc8b1b (Mono
JIT Code) Google.RunOnMainThread:<ExecuteAll>m__A ()
0x0000027f44bc8906 (Mono JIT Code) Google.RunOnMainThread:RunAction
(System.Action) 0x0000027f44bc876b (Mono JIT Code)
Google.RunOnMainThread:ExecuteAll () 0x0000027f63c2e510 (Mono JIT
Code) UnityEditor.EditorApplication:Internal_CallUpdateFunctions ()
0x0000027fa907c115 (Mono JIT Code) (wrapper runtime-invoke)
object:runtime_invoke_void (object,intptr,intptr,intptr)
0x00007ff8df51e274 (mono-2.0-bdwgc) mono_jit_runtime_invoke (at
C:/build/output/Unity-Technologies/mono/mono/mini/mini-runtime.c:3445)
0x00007ff8df45eb74 (mono-2.0-bdwgc) do_runtime_invoke (at
C:/build/output/Unity-Technologies/mono/mono/metadata/object.c:3066)
0x00007ff8df45ed0c (mono-2.0-bdwgc) mono_runtime_invoke (at
C:/build/output/Unity-Technologies/mono/mono/metadata/object.c:3113)
0x00007ff6080d9d14 (Unity) scripting_method_invoke 0x00007ff6080b7e34
(Unity) ScriptingInvocation::Invoke 0x00007ff6080b2a85 (Unity)
ScriptingInvocation::Invoke<void> 0x00007ff608201e6b (Unity)
Scripting::UnityEditor::EditorApplicationProxy::Internal_CallUpdateFunctions
0x00007ff608c04817 (Unity) SceneTracker::Update 0x00007ff608d26e99
(Unity) Application::TickTimer 0x00007ff60919e16a (Unity)
MainMessageLoop 0x00007ff6091a39d0 (Unity) WinMain 0x00007ff60a587dbe
(Unity) __scrt_common_main_seh 0x00007ff935697344 (KERNEL32)
BaseThreadInitThunk 0x00007ff9358a26b1 (ntdll) RtlUserThreadStart

I also got a warning about dependencies conflicting (not sure if it relate to this problem)

Some conflicting dependencies were found. The following dependency
versions were modified:
com.google.android.gms:play-services-ads-identifier:18.0.1 -->
com.google.android.gms:play-services-ads-identifier:+
com.google.android.gms:play-services-basement:18.1.0 -->
com.google.android.gms:play-services-basement:+
com.google.android.play:app-update:2.0.0 -->
com.google.android.play:app-update:+
com.google.android.play:core-common:2.0.0 -->
com.google.android.play:core-common:2.0.+
com.google.games:gpgs-plugin-support:0.11.01 -->
com.google.games:gpgs-plugin-support:+
com.ironsource.sdk:mediationsdk:7.5.1 -->
com.ironsource.sdk:mediationsdk:+ com.unity3d.ads:unity-ads:4.8.0 -->
com.unity3d.ads:unity-ads:+
com.unity3d.mediation:adcolony-adapter:[1.0,2.0[ -->
com.unity3d.mediation:adcolony-adapter:+
com.unity3d.mediation:admob-adapter:[1.0,2.0[ -->
com.unity3d.mediation:admob-adapter:+
com.unity3d.mediation:applovin-adapter:[1.0,2.0[ -->
com.unity3d.mediation:applovin-adapter:+
com.unity3d.mediation:facebook-adapter:[1.0,2.0[ -->
com.unity3d.mediation:facebook-adapter:+
com.unity3d.mediation:ironsource-adapter:[1.0,2.0[ -->
com.unity3d.mediation:ironsource-adapter:+
com.unity3d.mediation:mediation-sdk:[1.0,2.0[ -->
com.unity3d.mediation:mediation-sdk:+
com.unity3d.mediation:unityads-adapter:[1.0,2.0[ -->
com.unity3d.mediation:unityads-adapter:+
com.unity3d.mediation:vungle-adapter:[1.0,2.0[ -->
com.unity3d.mediation:vungle-adapter:+

0x00007ff6081c282d (Unity) StackWalker::GetCurrentCallstack
0x00007ff6081c77d9 (Unity) StackWalker::ShowCallstack
0x00007ff609197831 (Unity) GetStacktrace 0x00007ff609855d52 (Unity)
DebugStringToFile 0x00007ff6070f6db6 (Unity)
DebugLogHandler_CUSTOM_Internal_Log 0x0000027f44b2eaa3 (Mono JIT Code)
(wrapper managed-to-native) UnityEngine.DebugLogHandler:Internal_Log
(UnityEngine.LogType,UnityEngine.LogOption,string,UnityEngine.Object)
0x0000027f44b2e71b (Mono JIT Code)
UnityEngine.DebugLogHandler:LogFormat
(UnityEngine.LogType,UnityEngine.Object,string,object[])
0x0000027f44b2e460 (Mono JIT Code) UnityEngine.Logger:Log
(UnityEngine.LogType,object) 0x0000027fa94905a8 (Mono JIT Code)
UnityEngine.Debug:LogWarning (object) 0x0000027f44bc575b (Mono JIT
Code) Google.Logger:Log (string,Google.LogLevel) 0x0000027f4716163f
(Mono JIT Code) GooglePlayServices.PlayServicesResolver:Log
(string,Google.LogLevel) 0x0000027fa942f74b (Mono JIT Code)
GooglePlayServices.GradleResolver/<GradleResolution>c__AnonStoreyF:<>m__18
(GooglePlayServices.CommandLine/Result) 0x0000027fa942f535 (Mono JIT
Code)
GooglePlayServices.GradleResolver/<GradleResolution>c__AnonStoreyF/<GradleResolution>c__AnonStorey10:<>m__28
() 0x0000027f44bc942a (Mono JIT Code)
Google.RunOnMainThread:ExecuteNext () 0x0000027f44bc8b03 (Mono JIT
Code) Google.RunOnMainThread:<ExecuteAll>m__A () 0x0000027f44bc8906
(Mono JIT Code) Google.RunOnMainThread:RunAction (System.Action)
0x0000027f44bc876b (Mono JIT Code) Google.RunOnMainThread:ExecuteAll
() 0x0000027f44bc6233 (Mono JIT Code) Google.RunOnMainThread:Run
(System.Action,bool) 0x0000027fa942f4b3 (Mono JIT Code)
GooglePlayServices.GradleResolver/<GradleResolution>c__AnonStoreyF:<>m__27
(GooglePlayServices.CommandLine/Result) 0x0000027fa942f2c5 (Mono JIT
Code) (wrapper delegate-invoke)
<Module>:invoke_void_CommandLine/Result
(GooglePlayServices.CommandLine/Result) 0x0000027fa942f1ea (Mono JIT
Code)
GooglePlayServices.CommandLineDialog/ProgressReporter:SignalComplete
() 0x0000027fa942f19b (Mono JIT Code)
GooglePlayServices.CommandLineDialog/ProgressReporter:CommandLineToolCompletion
(GooglePlayServices.CommandLine/Result) 0x0000027fa942f0f5 (Mono JIT
Code)
GooglePlayServices.CommandLine/<RunAsync>c__AnonStorey0/<RunAsync>c__AnonStorey1:<>m__4
() 0x0000027f44bc942a (Mono JIT Code)
Google.RunOnMainThread:ExecuteNext () 0x0000027f44bc8b03 (Mono JIT
Code) Google.RunOnMainThread:<ExecuteAll>m__A () 0x0000027f44bc8906
(Mono JIT Code) Google.RunOnMainThread:RunAction (System.Action)
0x0000027f44bc876b (Mono JIT Code) Google.RunOnMainThread:ExecuteAll
() 0x0000027f63c2e510 (Mono JIT Code)
UnityEditor.EditorApplication:Internal_CallUpdateFunctions ()
0x0000027fa907c115 (Mono JIT Code) (wrapper runtime-invoke)
object:runtime_invoke_void (object,intptr,intptr,intptr)
0x00007ff8df51e274 (mono-2.0-bdwgc) mono_jit_runtime_invoke (at
C:/build/output/Unity-Technologies/mono/mono/mini/mini-runtime.c:3445)
0x00007ff8df45eb74 (mono-2.0-bdwgc) do_runtime_invoke (at
C:/build/output/Unity-Technologies/mono/mono/metadata/object.c:3066)
0x00007ff8df45ed0c (mono-2.0-bdwgc) mono_runtime_invoke (at
C:/build/output/Unity-Technologies/mono/mono/metadata/object.c:3113)
0x00007ff6080d9d14 (Unity) scripting_method_invoke 0x00007ff6080b7e34
(Unity) ScriptingInvocation::Invoke 0x00007ff6080b2a85 (Unity)
ScriptingInvocation::Invoke<void> 0x00007ff608201e6b (Unity)
Scripting::UnityEditor::EditorApplicationProxy::Internal_CallUpdateFunctions
0x00007ff608c04817 (Unity) SceneTracker::Update 0x00007ff608d26e99
(Unity) Application::TickTimer 0x00007ff60919e16a (Unity)
MainMessageLoop 0x00007ff6091a39d0 (Unity) WinMain 0x00007ff60a587dbe
(Unity) __scrt_common_main_seh 0x00007ff935697344 (KERNEL32)
BaseThreadInitThunk 0x00007ff9358a26b1 (ntdll) RtlUserThreadStart

Any help would be appreciated a lot. Since I am totally hopeless right now. I have seen another person have the same issue at github. But no one has any working answer yet.

Same problem here.
Unity 2022.3.10f1, IronSource 7.5.1

The problem is blocking me from update UnityAds adapters.
In the past, I opened this ticket (#00352919) to IronSource. They did not answer.

This was a simple project setup that trigger the issue:

Unity 2021.3.28f1
IronSource 7.3.1.1 or higher
IronSource adapter - UnityAds 4.3.36.0 or higher
OneSignal 3.0.9 or higher (EDIT: OneSignal 3.0.5 or higher)
External Dependency Manager for Unity 1.2.175 or higher

I hope for any official news from Unity.

This are other reports of this issue:

https://forum.unity.com/threads/error-related-to-levelplay-update-2-files-found-with-path-meta-inf-kotlinx_coroutines_core-version.1493180/#post-9379175