Failed to find Build Tools revision 29.0.0 - Android Builds

Now from my all Android projects, I can’t able to export Android builds after updating library using Android Studio.
I was, again and again, getting the same error:

This project does not contain any kind of external plugins installed. Then also I was getting this error, just two days before it was working properly.

For building a project, Unity uses a stable version of the Build Tools and not an rc (release candidate).

The Android SDK path is usually C:\Users\AppData\Local\Android\sdk\build-tools
delete the 29.0.0-rc1 folder or move it out to anywhere.

I have the exact same error with Voxelbusters plugin, but I have no earlier experience.

I can not get it through android studio, 29.0.0 is not available to me, only rc1 and rc2 and it does not work with them.

Check here:

Have you tried updating your build tools through android studio ?

problem fixed here : Fix Android SDK is outdated | update android sdk unity - YouTube