Failed to Initialize 3D Graphics

whenever i try to run the program this is exactly what it says.

Failed to Initialize 3D Graphics

Failed to initialize Direct3D 9. Make sure you have DirectX 9.0c installed, have drivers for your graphics card and have not disabled 3D acceleration in display settings.

I run Unity on XP machine in virtualBox.

In “dxdiag” “Direct3D Acceleration” and “AGP Texture Acceleration” are both disabled. Can I somehow remedy it (by remedy I mean run Unity despite those disables) or I have to move to the normal windows?

I think this is pretty clear :

and have not disabled 3D acceleration in display settings.

Unity is a 3D engine, therefore you need 3D acceleration.

The disable buttons on my dxdiag are not even highlighted and can not be clicked. I have DirectX9.0c installed though. So what am I missing?