Failed to locate Unity.exe ???

Hello I Tried to Install Android Support for Unity . But I keep Getting this error : Failed To Locate Unity.Exe

Any Help Please , I have a project :frowning:

Thanks in Advance …

@WAELK

tl;dr: Solution: Select Unity’s install folder (e.g. C:\Program Files\Unity )

I had this problem too. I assumed because it asked me to select a Destination folder that I should do just that, but what it actually wants is Unity’s root folder.

Examples:

Error reproduced by selecting: C:\Program Files\UnityAndroid  (A folder I made to install it into)
Error solved by selecting: C:\Program Files\Unity (Where I originally installed Unity)

I had the same problem but now because I’m using Unity Hub, so I believe a lot of people may come here and the solution of this ticket will not help, so I’m posting how to solve this problem if you have Unity Hub.

  1. Open Unity Hub and find the version you want to install the Support, in my case WebGL support

  2. Then find the support lib and add the component to this Unity version

  3. Then finally you wait, there’s no progress but there’s a indication of installing component on the place of the 3 dots, once it disappears it means component installed.

If you have Unity HUB than go to C:/Program Files/ Unity/Hub/Editor/“Unity version folder”

Unity version folder is 2018.3.10f1 for example.

Cheers

Thanks a lot!

I had this problem too. Resolved choosing Unity root folder. I really don’t understand why it let me choose the destination folder

The installer expects the folder structure inside the unity root folder to be a certain way. If none of the other solutions work for you check this as well.

My folder structure looked like this:

\Program Files\Unity\Editor\2020.3.1f1\Unity.exe

But what the installer is expecting is that you have a folder structure where after the version directory there’s an Editor subdirectory inside which the unity exe is located, so changing my path to the following fixed it for me:

\Program Files\Unity\Editor\2020.3.1f1\Editor\Unity.exe