Failed to Start Unity Package Manager Unity version 2017.3

Hi,
I updated to Unity 2017.3 yesterday and now I am getting this error “Failed to start Unity Package Manager: operation timed out. Please see the Editor.log file for more information.”

I tried uninstalling and reinstalling unity with no success.

Any thoughts on how to fix this issue?

Thanks!

Hi @rondonax,

Same problem here… with the 2017.3.1f1 version…

have you find a method to fix this issue?

regards,

Hi,

First recommendation to fix this issue is to install the latest patch release for the major release you are using. We have fixed all known issues related to startup problems where the Package Manager is involved. You can download latest patch releases here: https://unity3d.com/unity/qa/patch-releases

If the issue persist after updating to the latest version. Please follow these guidelines:

1) The Unity Package Manager process (upm-win.exe on Windows or upm-macos on macOS) is signed and marked as legit. Anti-virus software should not block the process for most part. But, we still sometime get reports from users of this happening. Try to whitelist the process in your anti-virus software configuration (refer to your anti-virus software documentation to learn how to do it).

2) By default Unity http request to the package manager process do not goes through the proxy if you have one configured. But you can break this by accident if you have not overridden the `UNITY_NOPROXY` environment variable properly. If you did override this env var, make sure to include `127.0.0.1` in the list of addresses that should not go through your proxy (ex: `UNITY_NOPROXY=127,0.0.1,....`

3) There is a bug in March 2018 beta release of Windows Defender. This bug affects many softwares and Unity is one of those.

Until Microsoft fix the issue, the workaround they posted is to revert the antimalware platform to the version before the Beta. From an elevated command line prompt:

`"%programfiles%\Windows Defender\MpCmdRun.exe" -resetplatform `

If this solution still does not work for you. Try this solution instead (thank you @RobertRy!):

1. Open the Windows Defender Security Center (you can find it by typing Windows Defender in the Windows 10 search box)

2. Open the item called "Virus & threat protection" - it is the one with the shield icon

3. Click on the "Virus & threat protection settings"

4. Scroll down to "Exclusions"

5. Click on "Add or remove an exclusion"

6. Click on the plus sign "+ Add an exclusion"

7. Select the last exclusion type with the name "Process"

8. Type the name "upm-win.exe" into the box and click on "Add"

9. Close the Windows Defender Security Center 10.

That's it!

If after trying these workarounds you are still enable to start Unity, please report a bug so we can investigate further and resolve the problem for you and others: https://unity3d.com/unity/qa/bug-reporting

Regards,

Pascal

I have just developed the same problem. This happened after a windows 10 update on March 14 2018. I am about to try the anti-virus whitelist thing but I’m sure it’s to do with the Win10 update. Minecraft also stopped me logging in to my realm - probably the same issue.

Just an update which may or may not help. I could not resolve this issue no matter what I tried. In the end I determined (as far as I could tell) that it was a definite problem with the Win 10 update. I read somewhere since that Win 10 may give problems on some “older computer” configurations. I don’t know if that is true or not but Because I had the Win 10 upgrade from Win 7, I was able to completely reformat my hard drive and reinstall my original Win 7. I then rebuilt my hard drive including Unity 2017. Everything worked perfectly. No more problems. However, my computer was about 5 years old with fairly average specifications so I decided to get a new computer. My new computer has quite high specifications and is running Win 10 and Unity 2018.2.2 without any problems at all. If you have this problem it may simply be that your machine is one of the unlucky ones that can’t run Win 10 properly???