Failed to update Android SDK Package List - Unity 2019.2.10f1

When I try to export the game build for the Android platform, I started getting this error:

Within the Project Settings - Minimum API Level and Target API Level not get loaded anyhow! While I have used all default Unity provided settings to export Android build. Here is the image to illustrate this:

Now what to do to solve this error?

I have already read all the threads related to same problem but overall I can’t able to find the solution that actually worked for me.

step 1 - Disable all checkmarks in preferences and close editor.
step 2 - Reopen the editor Enable all checkmarks in preferences after that hit the play button.
Now it will start resolving dependencies for android and the problem will be solved

Remove tick and select again.


  1. Project Settings > Player > Target API Level: Change “Automatic” to “Android 11” (or else)
  2. Play once and Stop.
  3. Change target api level to Automatic.

I don’t know if the problem is the same, but this is how I handle it every time.

I had the same issue. After I uninstalled Java SE Development Kit version 12, installed version 8 and rebooted, it was solved. Hope it helps you as well.

Java SE Development Kit 8u144 downloads.

This StackOverflow answer helped me.

Problem fixed here : Failed to update Android SDK package list - YouTube

remove a tick from NDK ,


hey this a simple and short tutorial that show what to do

@siddharth3322 I make JAVA_HOME equals Unity JDK
Video Solution : Failed to update Android SDK package list | Easy Error Solution Unity / Solução fácil Unity - YouTube

Hello, i have a similar problem, where i have downloaded and installed the latest jdk, sdk, ndk, and gradle. I set my minimum API key to 26. Iam making an AR app with AR foundation, i have already set everything, but when i hit “build” under the android, i get the same problem of “failed to update sdk package list”
please help me out, guys

alt text

For those who have unchecked the ticks already do the reverse this…

check them first
and uncheck them

worked for me

Just Run your application once properly and then try again to BUild.

For me, removing Java installed with Jenkins solved the problem.
Although there is a checkbox for this in Unity. But it doesn’t always help. On another computer (working server), Jenkins, Java and the Unity build work great together, in the same projects.