fatal error

Unity worked fine the first time I used it. 2nd time I get this error “Creating Directory” creating directory temp failed. please ensure there is enough disk space and you have permissions setup correctly. try again, cancel or quit. I hit cancel then I get fatal error, it looks like another unity instance is running with this project open. Multiple unity instances can’t open the same project. Project: E:/Chapters/Chapter 3. I’ve loaded this on 3 different PC’s 1 of the pc’s is brand new and the same thing has happened on all 3.

What permissions is it talking about? what other instance is running if I can’t open it?

any help is appreciated

To prevent the error message (and allow Unity3D to start), rename the project folder entirely. Next time you load Unity3D all should be fine and it will ask you to choose a project.

This works both in Windows and OS X.

I’ve solved this problem by deleting the “library” which is generated by unity.
My unity directory is as following:

Unity

|

  • ---- Assets

  • ---- Library <------ delete the directory, and reopen the unity

  • ---- Log

  • ---- ProjectSettings

  • ---- Temp

Takuan says:

If this problem is persistent, and the above answers do not help, here is what worked for us: Go into your project’s folder, locate and delete the Temp folder inside your project folder, and restart Unity. Everything should load fine now. Presumably, the problem lies in the fact that Unity creates a lock file in the Temp folder (at least on Windows). When Unity crashes, it does not delete the lock file, so you must manually delete the file.

So try that and let us know how it goes.

Hey guys, I’ve only been using Unity for a few days and I struck this problem. After cleaning out my disk space and trying (but failing) to access my last project’s temp files I made a last ditch effort. I checked the windows task manager. There were no applications running but I checked Processes and saw the Unity program ‘MonoDevelop’ was running. I shut that down and everything’s back to normal. facepalm

I can’t find the Temp folder in my project’s folder…

all I see are ‘assets, library, and Projectsettings’

i had to clear the registry from the last opened project.

I had this same issue on the mac and fixed it by changing the permissions on the root project folder.
Here is one easy way to do it: here

On windows:

  • Open your task manager → Processes tab
  • There is a button in the bottom-left of the window, ‘Show processes for all users’. Press it
  • A new unity.exe process should show up in the task manager. End it.

You should be able to restart Unity now.

Here is what helped me since I am testing this software on Windows 10.

Right Click the Unity Icon
then click “Run as Administrator”

Additional step that I took was elevating the process to be the top priority from within the task manager (Though I really doubt this last part does anything)

I had this problem come up on Win7, and like insominx, solved it by changing the permissions on my Projects folder. If you change the default location of your projects folder to one under any of the Unity installation’s folders, it will inherit the permissions and refuse to open.