FB.AppRequest sent successfully on iOS device, but there is no notification on target user's device

I am trying to integrate facebook functionalities into my mobile game. So I

  1. Download the facebook sdk for unity from here Unity SDK - Documentation - Meta for Developers
  2. Follow the tutorial (create facebook app, set up ios bundle id, etc) and make a iOS build from the demo included in the sdk package.
  3. Run the build on iOS device.

Then I test the functionalities: FB.Init, FB.LogInWithReadPermissions, FB.ShareLink all work fine. But when it comes to FB.AppRequest, something goes wrong.
Basically it seems that the request is successful because from the logs I can see that the error is null, and request id is a valid number. But somehow the target user(s) don’t get notification on their ios devices.

I searched on the web and tried very possible suggestion that I can find related to this issue but still no luck. For example:

  1. I tried sending app request to tester/developer/non-tester on facebook, none of them received my invites on their devices.
  2. I tried making my facebook app public, still not working.
  3. I noticed people saying that “setup the facebook canvas solve this issue”. But since my game is on mobile devices only, there is no facebook canvas url for me to set up.
  4. I noticed people saying “facebook places the invitation in a obscure place”, and I checked the game activities and no invitation come through.
  5. The didn’t change any code in the example included in the sdk package. So the code is quite simple FB.AppRequest(“Test Message”, callback: this.HandleResult); and it should work. I feel that it must be a little thing or step that I missed or mis-configurated that cause this issue.

Currently I am using Unity 5.5.2p2 with the facebook sdk 7.9.4.

Have you fixed this issue, I had the problems I can invites but there are no callbacks. (Work on Android but not work on iOS)


Edit

I found solutions it’s because callback from iOS is different from Android.
The variables “to” is had “” (Android doesn’t had).