FBX Animation not Playing


I’ve spend the last week watching tutorials and wading through the countless other “problems with fbx animation” threads, and still can’t fix my character animation.

I modelled, rigged, and now animated a character in Maya. But exporting it as an fbx and then importing it into Maya isn’t working at all. I want to use the animation in a Mechanim controller, so I set the rig to “generic” and select my root node (as a note, I’ve also tried using the Legacy setting here, but that doesn’t fix anything for me either). The model itself displays correctly and I can drop it into the scene, but it doesn’t animate at all. In the Animation tab under the model import settings, the model includes a “Take 001” object with the correct number of frames, but playing the animation in the preview doesn’t animate.

I’ve tried exporting from Maya in all sorts of different ways: selecting just the joints and mesh and baking my keys; using the “export all” function and baking; using the built-in “bake animation” function under the “Animation” tab in the export fbx options… All of these give me the same effect.

The model animates perfectly in Maya, I hope someone can give me some help to get it into Unity!

two years later you might not be looking for an answer any more, but someone else might be having it . i had the same problem with fbx from blender. there was a choice “version” where the default was without animation. when i imported in to unity there was still an animation object with the correct length of animation but nothing would move. I changed the version and the animation would “work”. except the model would collapse to a goldfish. still trying to resolve that.