FBX model loaded from AssetBundle not visible but is there.

We upgraded from 2018.4.12 to 2019.2.15 and everything worked except when we loaded .fbx models from an assetbundle. The model would be there because we could interact with the colliders but we can't see the model. As a test I put a .fbx file in the resources folder and loaded it from there and I can see the model, its just whenever we load it from an assetbunde we can't.

Also when running it in the Unity Editor we can see the model just not in the HL2 emulator. I believe the main change from 2018.4.12 -> 2019.2.15 is that we can no longer use the .NET scripting backend. Both the assetbundle and app are built on the same version of Unity with the same scripting backend (IL2CPP).

Any ideas on what it could be would be much appreciated!

More info:

Visual Studio 2019

HL2 Emulator 10.0.18362.1042 (also tried .1019, .1028 & .1034)


This is now fixed. All I had to do was re-apply the shader (not sure why), like this:

material.shader = Shader.Find(“Mixed Reality Toolkit/Standard”);