[Feature Request] Run As Administrator

Could there be an option to have the Unity Hub open the editor in Administrator mode? The editor has to be opened in that mode in order to initialize the Steam API.

Hi there,

Thank you for your feedback.
Our product team constantly monitor the feedback requests and prioritize them.

Best,
Afshin

1 Like

Hello!

I'll throw in that this also affects certain consoles that require us to run Unity in admin mode in order to automatically run their packaging batch files. Not fixing this more or less renders the Hub useless to us!

Thanks,
Bryant

2 Likes

Just to let you know that in Windows10 if you are a User Standard type If I open the editor in Administrator mode, Unity looks different than not opening as an administrator. And the game compile or projects are different (looks different)
As a workaround, you can give to the main project folder total control.

It is possible (at least under Windows 10). A separate option in the Hub would be nice though.

Here is how you do it:

  • For this to work, Unity Hub also has to run as Administrator.

  • Go to the Installation folder of UnityHub and open properties (Alt + Enter) of UnityHub.exe

  • Open the "Compatibility" tab, there you will find a checkbox Run as administrator

  • Now we can do the same for Unity.

  • Go to the "Editor" folder of the Unity installation you want to run as administrator.

  • Set Administrator settings for Unity.exe (see instructions above)

  • Fully exit Unity and Unity Hub

  • Restart Unity Hub, you should see the Windows dialogue for "Run as administrator"

  • Open a project using the Unity version you customized. You won't get another "Run as administrator" prompt, but Unity will have Admin permissions.

10 Likes

Thanks for @derClef answer, but probably you have problem with dropping objects to unity, it happens when unity is running as admin, you can just cpy and past your files directly using explorer instead of direct dropping.

Using this technique, Unity Hub opens as a blank window
6769717--782443--upload_2021-1-26_20-57-24.png

3 Likes

same here, how to run unity editor as admin then ????

same thing happened to me, after enabling to run as admin Unity Hub is showing blank window. But it is fixed after I close it and force kill all Unity's process from task manager

6 Likes

Hey folks!
Thank you for raising this with us!
As @afshinity said, we're constantly monitoring the feedbacks and bringing it to the Hub team.

I'll close this thread as it's going for some time now, but feel free to create a new one for new issues, feature requests and whatnots.