Finally found solution to the 0xc000007b error at startup

Good day community, this is my first time posting a new thread so i might be violating some rules which am not aware of. I decided to make this post as to help those who went through the same frustrating situation as i did and haven’t yet found a solution to it.
I tried a couple of solutions ranging from reinstalling redistributables of both 32 bits and 64 bits to deleting previous windows updates to even almost locking my whole hard disk C: security so i will advise caution when taking solutions from the internet.

An application named (dependency walker) was used in finding out the cause of the 0xc000007b error by showing the application’s dependency (what the application needs in order to run). I noticed that a file msvcp140.dll was x86 in red unlike the rest which were x64 in black so i downloaded both the 32 and 64 versions of msvcp140.dll file from the internet in order to replace it. Sorry forgot the name of the site as to not give wrong site address. The msvcp140.dll location was directed to C:\Windows\System32 folder by the dependency app so i replaced it with the 32 bits version but that didn’t work so i tried the 64 bits version and the error 0xc000007b was solved.

As a reminder am not sponsored by the app listed above. Just decided to share my 11 days experience and solution to those in need. The culprit of your error might be a different file but at least the app can prove useful in solving such errors.

For me the solution to the problem with the same result and error were strong anti-exploit settings in Windows Security / Windows Defender.

Unity Hub hang in any attempt to install the latest 2020 Beta. Downloading worked, and the progress bar was visible in that “current installations” tile. But nothing further happened - it just hang.

Downloading and then running the 1.5 GiB UnitySetup64.exe resulted in the infamous 0xc000007b error after some seconds.

If you have Mandatory ASLR activated (the default is off):

In Windows Security navigate to App & browser control and Program Settings and add a program by program name: Choose UnitySetup64.exe and click OK.

After that the installer runs as expected.

2 Likes

You literally saved my day an job!

it is worked Thanks Man

This problem still persists.

Unity! How come you've been unable for learn to deploy your software on windows correctly since ASLR was implemented there.. [checks notes] 14 years ago?

Whenever i need to install a new Unity release, i have to do that in a VM (where the ASLR is disabled), and then copy the resulting "Editor" to the main dev machine.

No, disabling ASLR (and other mitigations) on a dev machine is not a correct "solution" to Unity's problems.

1 Like

What version of Unity is this? We fixed this issue a while back: https://issuetracker.unity3d.com/issues/windows-10-unity-installer-terminates-when-launching-with-aslr-enabled-in-the-registry

Specifically, this was an issue with the installer technology we used - the editor itself or games made in Unity were not affected, just UnitySetup64.exe.

2019.4.30f1 LTS (and 2019.4.17f1 for example).

And from install-log.json:

{"moduleName":"InstallerWinProcess","level":"info","message":"[ 'trying to connect to the ipc server' ]","timestamp":"2021-09-22T15:58:03.779Z"}
{"moduleName":"UnityIPCClient","level":"debug","message":"[ 'connecting to IPC Server Unity-hubInstallServer' ]","timestamp":"2021-09-22T15:58:03.779Z"}
{"moduleName":"InstallerWinProcess","level":"debug","message":"[\n  'Validation strategy: {\"destination\":\"A:\\\\\\\\Program Files\\\\\\\\Unity\",\"destinationFilename\":\"UnitySetup64-2019.4.30f1.exe\",\"installerFilename\":\"UnitySetup64-2019.4.30f1.exe\",\"installerPath\":\"A:\\\\\\\\tmp\",\"installerSizeInBytes\":1918990336,\"type\":0,\"uid\":\"2019.4.30f1\",\"editorVersion\":\"2019.4.30f1\"}'\n]","timestamp":"2021-09-22T15:58:03.809Z"}
{"moduleName":"Disk Validation Strategy","level":"info","message":"[ 'Executing the Install Validation Strategy...' ]","timestamp":"2021-09-22T15:58:03.809Z"}
{"moduleName":"Disk Validation Strategy","level":"info","message":"[ 'Validating destination path permission for access...' ]","timestamp":"2021-09-22T15:58:03.810Z"}
{"moduleName":"Disk Validation Strategy","level":"debug","message":"[ 'Destination Path: A:\\\\Program Files\\\\Unity' ]","timestamp":"2021-09-22T15:58:03.810Z"}
{"moduleName":"Disk Validation Strategy","level":"info","message":"[ 'Destination Path check: Passed' ]","timestamp":"2021-09-22T15:58:03.854Z"}
{"moduleName":"Disk Validation Strategy","level":"info","message":"[ 'Validating available disk space on the partition.' ]","timestamp":"2021-09-22T15:58:03.855Z"}
{"moduleName":"Disk Validation Strategy","level":"info","message":"[ 'Required space: 1918990336 bytes / 1.79 GB...' ]","timestamp":"2021-09-22T15:58:03.855Z"}
{"moduleName":"Disk Validation Strategy","level":"debug","message":"[ 'Available disk Space: 109398327296 bytes' ]","timestamp":"2021-09-22T15:58:03.856Z"}
{"moduleName":"Disk Validation Strategy","level":"debug","message":"[ 'Available Disk Check: Passed' ]","timestamp":"2021-09-22T15:58:03.856Z"}
{"moduleName":"Disk Validation Strategy","level":"info","message":"[ 'Validating accessibility of installer...' ]","timestamp":"2021-09-22T15:58:03.856Z"}
{"moduleName":"Disk Validation Strategy","level":"info","message":"[\n  'Verifying read and write accessibility to installer source path: A:\\\\tmp\\\\UnitySetup64-2019.4.30f1.exe'\n]","timestamp":"2021-09-22T15:58:03.856Z"}
{"moduleName":"Disk Validation Strategy","level":"info","message":"[ 'Installer Accessibility Check: Passed' ]","timestamp":"2021-09-22T15:58:03.857Z"}
{"moduleName":"Disk Validation Strategy","level":"info","message":"[ 'Validating presence of an existing installation...' ]","timestamp":"2021-09-22T15:58:03.857Z"}
{"moduleName":"Disk Validation Strategy","level":"info","message":"[ 'Verifying installation type: EDITOR' ]","timestamp":"2021-09-22T15:58:03.857Z"}
{"moduleName":"Disk Validation Strategy","level":"info","message":"[ 'Verifying presence of an existing editor installation...' ]","timestamp":"2021-09-22T15:58:03.858Z"}
{"moduleName":"Disk Validation Strategy","level":"info","message":"[\n  'Verifying presence of an Editor binary in path: A:\\\\Program Files\\\\Unity\\\\2019.4.30f1\\\\Editor\\\\Unity.exe'\n]","timestamp":"2021-09-22T15:58:03.858Z"}
{"moduleName":"Disk Validation Strategy","level":"info","message":"[ 'Existing Editor Installation Check: Passed' ]","timestamp":"2021-09-22T15:58:03.858Z"}
{"moduleName":"Disk Validation Strategy","level":"info","message":"[ 'Validating file integrity (checksum)..' ]","timestamp":"2021-09-22T15:58:03.859Z"}
{"moduleName":"Disk Validation Strategy","level":"info","message":"[ 'Checksum value not supplied. Skipping Checksum' ]","timestamp":"2021-09-22T15:58:03.859Z"}
{"moduleName":"Disk Validation Strategy","level":"info","message":"[ 'Checksum check: Passed' ]","timestamp":"2021-09-22T15:58:03.859Z"}
{"moduleName":"Disk Validation Strategy","level":"info","message":"[ 'Overall validation result: Passed' ]","timestamp":"2021-09-22T15:58:03.859Z"}
{"moduleName":"UnityInstallStepsWindows","level":"debug","message":"[ 'beforeEditorInstallation' ]","timestamp":"2021-09-22T15:58:03.863Z"}
{"moduleName":"UnityInstallStepsWindows","level":"debug","message":"[ 'execInstaller' ]","timestamp":"2021-09-22T15:58:03.864Z"}
{"moduleName":"UnityInstallStepsWindows","level":"debug","message":"[ 'installFromExe' ]","timestamp":"2021-09-22T15:58:03.865Z"}
{"moduleName":"UnityInstallStepsWindows","level":"info","message":"[\n  'install A:\\\\tmp\\\\UnitySetup64-2019.4.30f1.exe /S /D=A:\\\\Program Files\\\\Unity\\\\2019.4.30f1'\n]","timestamp":"2021-09-22T15:58:03.865Z"}
{"moduleName":"UnityInstallStepsWindows","level":"warn","message":"[\n  Error: Command failed: \"A:\\tmp\\UnitySetup64-2019.4.30f1.exe\" /S /D=A:\\Program Files\\Unity\\2019.4.30f1\n  \n      at ChildProcess.exithandler (child_process.js:312:12)\n      at ChildProcess.emit (events.js:315:20)\n      at ChildProcess.EventEmitter.emit (domain.js:483:12)\n      at maybeClose (internal/child_process.js:1021:16)\n      at Process.ChildProcess._handle.onexit (internal/child_process.js:286:5) {\n    killed: false,\n    code: 3221225595,\n    signal: null,\n    cmd: '\"A:\\\\tmp\\\\UnitySetup64-2019.4.30f1.exe\" /S /D=A:\\\\Program Files\\\\Unity\\\\2019.4.30f1'\n  }\n]","timestamp":"2021-09-22T15:58:37.352Z"}
{"moduleName":"InstallerWinProcess","level":"debug","message":"[\n  'Validation strategy: {\"destination\":\"A:\\\\\\\\Program Files\\\\\\\\Unity\",\"destinationFilename\":\"UnitySetup64-2019.4.17f1.exe\",\"installerFilename\":\"UnitySetup64-2019.4.17f1.exe\",\"installerPath\":\"A:\\\\\\\\tmp\",\"installerSizeInBytes\":1760144384,\"type\":0,\"uid\":\"2019.4.17f1\",\"editorVersion\":\"2019.4.17f1\"}'\n]","timestamp":"2021-09-22T16:15:04.732Z"}

2020 versions install w ASLR indeed, but larger projects are still on older LTS (or sometimes specific) versions.

7515038--926879--untiy.PNG

Yeah unfortunately we decided to not backport the fix to 2019.4 as it was deemed too risky (and at the time introduced multiple regressions in 2020.2 too).

https://www.youtube.com/watch?v=DlDnE2X4yVo

this solved the problem for me

Hello guys. This is the first time I'm writing a post so cut me some slack on the grammar I have a problem with Unity. When I installed UnityHub, I installed the Editor and added modules, then created a project. Now when I launched Unity it worked successfully with no problems. Then after sometime(about 2 weeks not using Unity), when I tried launching Unity it showed me that I was missing msvcp100.dll error, then when I copied and paste the files to the Unity directory, it then showed the application was unable to start correctly (0xc000007b). Click ok to continue. I haven't played with any directories or registers neither have I also edited files in Local Disc C: please can someone help me, I'll be grateful, thanks

bdw the only way that I resolved this problem was to reinstall Unity which is annoying I need another way

This error depend on the computer. mine worked after copying mscv120.dll at system32.Please check with dependency walker and find what dll file should replace.

This problem again and again. How to fix it. Now 24 april 2024 year {don’t know Englih very well}

1 Like

same here . looks like unity will never be able to create a stable version of its engine without us making hacking tricks to make it work properly

2 Likes

Any solution other than these ? none of them are working