first person controller doesn’t walk at all!

Please help, here is the issue. I have added the first person controller to my terrain then I pressed the play button, I tried to move around using the mouse or the keyboard but it did not move at all. I have watched some video tutorial on youtube where they just drag the FPC to the terrain and it starts walking straight away. I don’t know why it is not working for me. I am very new to Unity3D and I am stuck right at the first step. This is so frustrating. I really appreciate your help.

If you are on windows there is a bug sometimes will prevent user input (key press) to the game view. Normally you can fix this by “tabbing” out of Unity and tabbing back in.

Finally! Sorted. This is how it is done. Click on file new project then select Character Controller.unity pakage. Then add a terrain to the project then drag a first person controller, press play button and it should move nicely.

This appears to be a bug. I’ve solved it by closing unity and opening again the same project.