First Person Controller will not move

My First Person Controller will not move when I click on Play. I'm using the Standard Assets Prefab FPC.

You probably have two Main Cameras in your scene. One connected to the FPC and one alone. If you do, you need to delete the camera that is alone, not connected to the FPC.

I hope this helps you.

I had the same issue and now sorted. This is how it is done. Click on file\ new project then select Character Controller.unity pakage. Then add a terrain to the project then drag a first person controller, press play button and it should move nicely.

Hi genius,
First you should go to Standard assets → Character controllers → Sources → Scripts.

then you will see a JavaScript file called CharacterMotor.js

Drag the CharacterMotor.js to your Main Camera in the hierarchy window.

Ensure that your Main Camera must placed in FirstPersionController’s child object.

you may know the Game Object is FirstPersionController . FirstPersionController object has two child objects one is Graphics and another Main Camera. Remember that you must drag the CharacterMotor.js file to this Main Camera.
(Your main camera is the one that when you click play, and enjoy with Unity.)

@ philosopher51x, Just find Mobile Input in Menu Bar and disable it.

Check for:

  1. Movement speed of FPS
  2. Colliders nearby
  3. Console for the issues (if any reported by Unity).

Go to FileBuild Settings and change your platform to Windows. It should work now.
@philosopher51x