FIXED (Character moving on its own strangely + low poly terrain)

I’m following the GTGD unity tutorials, and have the latest possible free Unity version.

After I tried out the Medieval Environment Pack, my terrain textures suddenly became really low quality (meaning, instead of being detailed they were looking like simple 1-color materials). I googled it and the answer was a shader that was included in this Pack, after I deleted it, everything went back to normal. I saved the project and quit.
The next day when I opened it again, the terrain was buggy again! Even though I had no shader in the project folder. I googled for days but couldn’t find an answer. It is still the same.
I tried making new terrains, with GeoControl, with Fractscape - but I didn’t want to buy it so I couldn’t save it, and with the Terrain Toolkit. I imported the textures I was using into Fractspace, and they looked normal, so the texture files are not corrupted / modified. Something is wrong with Unity itself or something else is conflicting with it.

A few days passed and another bug appeared (I imported a few files into the project, but I didn’t add them into the scene or used them in any way!)
Whenever I launched the game, my character started walking in its current rotation and slightly to the left. I have no idea why this is, I changed nothing in any scripts either.

Now, what is really boggling my mind: I had built my game in Web Version, and put it on my website. This was before any bugs appeared. Now, whenever I launch that, my character moves automatically the same way!!! I did not build it again into Web Version!!
But, whenever someone else launches it from my website, there are no bugs for them.
So, my Web Player is buggy too somehow.

I tried reinstalling Unity, but now, right after launching, Unity crashes. Not because it wants to open the last project and that is corrupted somehow, it just crashes on its own.

Any suggestions would be appreciated. I’m really stuck here and it bothers me really much.

#Update
Okay, so I reinstalled Unity again (I had beast64.dll and umbraoptimizer64.dll left over from the previous installation - that might’ve caused the crashes) and I fixed the low poly terrain issue - my Base Map Distance was set to 1. Now I set it to 2000, it is still not crisp but it never was.
My character is still moving on its own though.

#Update 2
Okay so I’ve been cursing for 15 minutes straight now.
I have had a virtual joystick installed. (VJoy)
I uninstalled it when this bug first appeared but it did not solve anything so I forgot about it. What I did not check is that it still existed in my virtual hardwares.
So after deleting it, everything’s fine, but I basically fucked up my nearly-ready project and scene with trying out bazillions of stupid things. Oh well.

I don’t know if I have to delete this question now, well at least it can be of good advice to others.

Had the same problem. I had a 3DConnexion navigator installed and no more unwanted movement after I uninstalled it. Disabling it or having it disconnected had no effect for me.

I had the same problem so im glad you didn’t remove your question.
Especially when you started talking about how you fixed it by removing VJoy.
I also have VJoy and I never really used it so I think just by having it cases
the problem. removing it now to see if it works.

Confirmed!
All I did was remove all the VJoy installations and the VJoy virtual device and the problem was solved.

Thanks :slight_smile:

Thanks Mate I was so much confused searching for solution for almost 10 day but no luck.I made threads in forums asked unity sent a bug to unity but still no luck You really helped me. . . vjoy was also installed on my computer . . .i installed it for don bradman now i unistalled and the problem was fixed. . . .thanks again mate :wink: