FIXED - Editing animation clips gives NaN on rotation value

Hi all,

I have a waving animation which I’m trying to edit. So I duplicate the clip (.anim file) so I have a non read-only clip I can edit in Unity.

I edit some keyframes on the arms to make them stick out more so they avoid clipping through the waist - however I notice a flicker right at the end of the loop. On investigating the frame further, I noticed that the Y rotation for the arms was returning NaN, making the arms dissappear on that frame.

I tried deleting the last keyframe (the one which was returning NaN) and the problem ocurred on the “next” keyframe -ie what was the second to last (and now last) keyframe. It always occurs on the last keyframe on the anim clip.

I only moved the frames a little bit - there are no crazy jags or spikes in the anim curve. I can’t think whats causing this and would really appreciate any advice - it would really help my workflow to be able to edit anim clips in Unity.

The Unity 3.5 beta addresses this issue.


Nope. It still happens in the latest version of Unity.

(currently looking for a fix.) This happened when I tried to parent an animated object in a program before bringing it to Unity. It worked fine un-parented. As soon as I parented it, it would no longer accept the animation.

Moral of the story; ???