Fixing lighting bug in unity 2017.1

When loading a level in unity via SceneManager.LoadScene, it is way darker than it should be. As far as I can tell, this has been a bug for many many years, and I found many fixes, that say to “go to Window → Lighting → Lightmap Tab → Disable Continuous Baking → Press Build to bake the lighting once manually”. I don’t seem to find such setting in Unity 2017.1. Am I missing something, or is there a new way to fix that?

1- Go to Window → Lighting → Settings.

Now you you have a new window of light settings


2- On the new window under the Scene tab: check off “Auto Generate” and then click “Generate Lighting”.

This will make a folder of lighting information for the current scene so that there is no need for recalculation on loading. Do this for all your scenes and the problem should be solved.