Fixing URP Shader Conversion Issues for Particles

Any insight on how to fix these fire particle shader errors?

Image from Gyazo

These warnings come from the Fallback Shader Conversion process that tries to convert materials based on common properties (_Blend, _Cull, etc.). If you disable that setting in the PolySpatial project settings, then you won’t get the warnings, but that won’t make the materials work.

If you’re using the Replicate Properties particle system mode, then you need to use one of the supported particle shaders: “Universal Render Pipeline/Particles/Unlit”, “Universal Render Pipeline/Particles/Lit”, “Particles/Standard Unlit”, or “Particles/Standard Surface”. If you’re using Bake to Mesh particles, then you should be able to use those or a shader graph material.

1 Like