force scrollrect only to scroll with scrollbar

Hi, for my mobile game I have a scrollRect with many Elements that are all interactable. I got annoyed that when scrolling the Elements on my mobile device I accidently pressed on of the buttons and vice-versa. So I decided to add a ScrollBar to control the movement of the scrollRect exclusively. Adding the scrollBar is straightforward, unfortunately I don’t know how to “deactivate” the scrollRect so it doesn’t move when the scrollRect area is touched (s. picture). I tried to set the RectTransform of the ScrollRect to zero but that didn’t help.

I believe all you have to do is uncheck the “horizontal” and “vertical” checkboxes of your ScrollRect. The scrollbars will still function but dragging the content and scrolling with the mouse wheel while hovering the content doesn’t work.

I’m assuming the same applies for touch, although I haven’t tested it yet.