Foreign language true type fonts rendering fine on Mac, but not on iPhone?

I've tried importing Japanese and Chinese true type fonts in to Unity. The fonts import correctly and the characters show up properly in the material.

The fonts import into the material in Unity with a size of 256x128 for the font texture. I am expecting since I did import them as font textures and set the font even as the default font for my GUISkin (as a test), it would definitely work, but no joy so far no matter which fonts I've tried.

When I run my app in locally on the iMac, the fonts render correctly using the foreign characters, but as soon as I deploy to the iPhone, the character render only in some default English font.

After trolling the forums, I haven't really seen a similar issue posted where rendering the font works fine on the Mac, but not on the iPhone.

Any ideas what's wrong here?

iPhone doesn't have dynamic fonts. This makes it hard/impossible to support huge character sets like Japanese fonts, since you're limited to 2048x2048 for a single texture, or 1024x1024 on older devices.