FPS way too high despite disabling vsync and setting target framerate.

So I’m having a lot of issues with my game being too GPU intensive. To fix this I tried to limit the framerate of the game. This is working fine except from the first scene of the game for whatever reason. When the game starts on my main menu, the FPS is over 2000 and I can hear my gpu screaming. In this scene I am disabling vsync and setting the target fps to 60. When I move to my actual game scene however, the fps is completely fine. What’s even weirder is that if i go to my game scene then back to my main menu the fps is normal. Does anybody have any idea why this is happening and how I could stop it?

Don’t set vsync to 0
just call targetFrameRate to set your FPS.