Frame debugger all over the place

The frame debugger is completely un-useable in 2021.2.
The profiles keep jumping all over the place, if you put it in play mode and pause it it will stay but if you click on any of profiles it will completely change the whole profiling layout selecting a random one.

1 Like

This is a known issue once you have some VFX Graph effects present. Disabling those would be a workaround for now. It's being fixed, but I don't recall which version the fix went in already.

I also have this issue with a fresh project without having VFX graph installed?

1 Like

[quote=“alexanderameye”, post:3, topic: 846096]
I also have this issue with a fresh project without having VFX graph installed
[/quote]
Then please file a bug!

1 Like

Forgot to respond to this, but yes this happens in default 2021.2 scene in URP without VFX graph. It appears to happen on and after the 'ColorGradingLut' in the profiler, also even with PostProcessing turned off the 'ColorGrading' pass is still happening which doesn't make sense to me? Filing a Bug report now

Already filed one and it was a 'known issue' with a fixed being worked on :)

https://issuetracker.unity3d.com/issues/frame-debugger-clear-events-constantly-appear-and-disappear

1 Like

[quote=“alexanderameye”, post:6, topic: 846096]
Already filed one and it was a ‘known issue’ with a fixed being worked on :slight_smile:

https://issuetracker.unity3d.com/issues/frame-debugger-clear-events-constantly-appear-and-disappear
[/quote]
Hopefully soon! I have been just putting it in play mode before using the debugger and it slows down enough for me me to check some things. Unfortunately I’m pretty sure it causes some sort of memory leak because twice now I’ve had hard Unity crashes that required me to complete restart the computer because my graphics card would start freaking out (not editor, my OS) after the crash… :frowning:

[quote=“CaffeinatedCoolaid”, post:7, topic: 846096]
Hopefully soon! I have been just putting it in play mode before using the debugger and it slows down enough for me me to check some things. Unfortunately I’m pretty sure it causes some sort of memory leak because twice now I’ve had hard Unity crashes that required me to complete restart the computer because my graphics card would start freaking out (not editor, my OS) after the crash… :frowning:
[/quote]

I believe there is a memory leak yes! At some point I saw it creating temporary buffers like crazy, they mention that in the issue tracker as well. I’m just not going to open the frame debugger for now haha. Also, beta 2 just released today but I don’t think I saw the fix in the release notes. Hopefully soon as you said.

While unfortunately the lasted version that just came out did not solve the issue, in fact it is worse. Now It only will show the depth target, its becoming really hindersome :(

1 Like

I'm confused, the issue says "Fixed in 2021.2.X" and the newer beta changelogs no longer mention this as a known issue, but I get the same behavior in the latest beta 2021.2.0b8 with the URP template scene...

[quote=“uwdlg”, post:10, topic: 846096]
I’m confused, the issue says “Fixed in 2021.2.X” and the newer beta changelogs no longer mention this as a known issue, but I get the same behavior in the latest beta 2021.2.0b8 with the URP template scene…
[/quote]
If it was mentioned as fixed in a beta changelog but still occurs in latest beta, then you should report it as a bug.

The b8 release notes say:

  • Graphics: Graphics: Fix flickering events in frame debugger. (1341163)
  • First seen in 2021.2.0a19.*
  • Fixed in 2021.2.0b9.*
1 Like

Okay, thanks. I looked at the changelog in the forum post and that entry isn't there, pardon my confusion. I see now that it says "Preview of ... Release Notes" on the spoiler there, my bad.

Am i to understand the frame debugger wont be fixed in the 2020.3 LTS?


Was it broken on 2020.3 LTS? Issue report said issue couldn't be reproduced on 2020.3.


Ever since we moved to 2020.3 i've been completely unable to use the Frame Debugger, instead opting to use RenderDoc, i recall seeing a bug report about it and ignored it figuring it'll get fixed eventually.

I should not however that we are on 2020.3.11f1 not 13.f1, we will be doing an update very soon so i'm making a note to myself to try using it again and see if it's fixed in the latest version, if not i'll file a bug report myself.

@JJRivers just to be clear, the reason you can't use frame debugger is because it keeps flickering different info all around it? Because that's what this issue is about. If you have some other issue, you should probably check if it's a known bug and if not, then report it somewhere.

Exactly the same issue.


Can you give URP / HDRP version where it does that for you?

Edit:
I just briefly tested this on both 2020.3.11f1 + URP 10.5.0 and 2020.3.18f1 + URP 10.6.0 and frame debugger works fine on all of those for me, none of the weirdness I saw on 2021.2.

On 2020.3.11f1 I threw in bunch of visual effect graph effects in the template scene and everything still worked fine.

1 Like

There's always a possibility that your issue is triggered by something else so if you can repro it on latest 2020.3 version, probably worth filing that bug report with it.