Full screen shader gets doubled in overlay camera

Hi,
I’m new to using fullscreen shaders in Unity, but I am struggling with a problem where I am trying to use overlay cameras to render the guns in my game seperately so they dont clip through walls, but I am noticing that when I add these overlay cameras to the stack, they layer the fullscreen shader effects on top of each other each time. post processing isnt enabled, clear depth doesnt help nor does render shadows or seemingly any of the render settings. Is there some way I can get around this?

Assuming you are using the Full Screen Pass Renderer Feature on a URP Renderer, that renderer profile/asset will affect all the cameras in your scene, by default.

One option would be to create a second renderer that does not have the Full Screen Pass Renderer Feature and add it to your URP Pipeline Asset’s Renderer List.

image

Then on these overlay cameras, you will have the option to assign that Renderer.

hth.