Game Objects don't appear on build but they do in the Scene and Game tab

Lately I have being developing my game and everything went right. It had been a while since I didn’t had done a build to my game. A day ago, I tried to see how my game was seen when played an the only thing that showed on my screen were the shadows of the Game Objects. The game can be played and everything works as in the editor, but there are no sprites. Moreover, the UI sometimes shows up ( I try to fix it but depending on the tutorial I follow they appear or not). Can anyone help, pls?? I’m running out of time and ideas… :frowning:

PS: I’m using an old Mac OS X and I don’t know if the problem might be with the bits my computer can handle (That’s what other answers mentioned ). Also, the camera is attached to a CinemachineVirtualCamera.

I have tried:
-Changing the Z.position of the objects.
-Checking all Layers and Tags are visible.
-Playing with the camera parameters.
-Restarting my computer.
-Trying to build the game for itch.io for my friends to try (this also hasn’t been posible due to some compiler errors)
-I have also read about changing Standard Shaders to Legacy Shaders for older computers but I couldn’t find the way.

This is how it looks:

And this is the approximation of how should look:

Do you use some Awake code or something? Sometimes a racing condition might prevent those boxes from initializing, leaving their game objects disabled. You can check if this is the case using two approaches:

  1. Try Debug.Log to see if your objects actually gets enabled. You can put something in Start(). It won’t trigger if the gameObject is not enabled.
  2. Use a runtime debugger asset to check the hierarchy. I use Debugger Essentials and it has been extremely helpful for me. It allowed me to see which objects are disabled. Then I was able to find out why (racing condition during init) and fix it in my code.