Game runs on a mobile device only when script debugging is enabled


I am having the strangest thing happen to me. When I run my game in unity, it works fine, but when Build and Run it on my mobile phone, it doesn’t work.

To be more specific, Particle Systems that I have pooled doesnt seem to exist. Anyways, in order to debug this, I clicked the Script Debugging check box under build setting. And now it works. When I uncheck Script Debugging, it fails on me again.

Any idea as to why this might be happening?

It works when I do not pool the Particle System (the particle system is suppose to play when an object is “killed.” I made the particle a child of that object, play the particle effect, disable collider/renderer of the said object, and used a coroutine to disable the object (to wait for particle effect to finish)). To report a bug report I will need to redo the pooling because like an idiot I didn’t save the bugged project before fixing it. I will recreate the bug and report when I get some free time.

Thanks everyone for the replies.