Game view is suddenly black

After spending a couple days modifying the Bootcamp demo without any problems, suddenly the view is now all black when running it in game mode, although the camera preview still shows the normal scene. The same problem occurs in other scenes for the same project, although it still works fine when running the Tropical Island demo project in game mode. Around the same time that the black screen problem developed, the editor was also refusing to save changes to the scene - it would make a "plink" sound when I tried to save it, and some of my changes were not saved. That problem cleared up after I restarted the editor, but the black screen problem is still there for this specific project. I assume I must have accidentally changed a setting, perhaps for the player camera? What setting would cause a problem like this?

Hi,

I had this same problem. Here’s what worked for me:
Right-click game scene tab > add tab > Game view.

This created a new game view tab that wasn’t black. As I had two game view tabs open, I closed one of the game view tabs and the problem was fixed.

I found a solution to my question, after searching this forum more thoroughly. If anyone else has the same problem -- you need to go to Edit->Project Settings->Time and change "Time Scale" to 1 (it becomes locked on the "pause" value sometimes).

Camera

  • Allow HDR
  • Allow MSAA

Set ONLY ONE of these ON (set the other OFF). It worked on Unity 5.6.7f1 on Windows 7 32 bits with built-in nVidia Geforce 7025/630a.

I had same issue after upgrade to 2019.1.2f1. Timescale was already “1” and re-adding Game tab didnt help too. What did helped was setting Camera’s Viewport Rect to anything slightly different from 0 (for example 0.00001)

Is some one using 2D Renderer with URP (universal rendering pipeline). You should chose your image in hierarchy → go to inspector and find Material → change it to Sprite-Unlit-Default.

p.s Press UP on my message if it helped you.

For me adding a new game view or setting the timescale to 1 didn’t help. Select the camera, go to inspector and you will see a section called “Camera” and there’s an option to set render type which has two option - Overlay and Base. Overlay was selected and as soon as i selected base it was fixed