Game without physics' physics using ~5ms a frame?

I’m currently making a 2D game in Unity. I’m using no rigidbodies, and no colliders, but physics is still taking up about 5 ms a frame. When enemies spawn it pops to about 7ms.

Other than colliders and rigidbodies what is considered “Physics” in the profiler?

I’m still about 5~7ms of overhead with Fixed Timestamp set to 10 (the max).

Collision detection is done in the scripts in 2D, so that should be showing up in the scripts section of the profilier, correct?

Also, no raycasting…

Edit: Actually, I think I figured it out. Client.Update() →
Mesh.Bake Scaled Mesh PhysX CollisionData is taking up just about the same amount of time as the “Physics” statisitic so that’s probably it.

So, the quest now becomes, how does one disable (or kill) Mesh.Bake Scaled Mesh PhysX CollisionData?

And… I found the cause. I added a plane object to display a shadow sprite, which defaults to having a mesh collider(?), which was then scaled causing massive amounts of lag for absolutely no reason! Whoo!

The answer was here:
http://forum.unity3d.com/threads/65346-What-is-quot-Bake-Scaled-Mesh-Physx-Collision-Data-quot

Raycasting is one of them. Sounds like you use some kind of collision detection anyway and that is still physics, be there forces calculations involved or not.

The physics simulation still runs. You cannot disable this, but you can tell the physics to basically “never update” by raising the fixed step length in the editor settings - time settings to a very high value.
Just be aware that this also impacts all collision.

(this answer was found on Unity forum: http://forum.unity3d.com/threads/68551-Disable-Physic-Calculation-for-mobile-platforms )