Game Wont Open After Build (.exe, windows 7, 32 bit)

Hello all, thank you for taking the time to read this.

I just completed my first game ever, and I successfully have it built and running on my android device.

However, when I build it for PC, the exe will not open. In task manager, it says I have 3-4 of the executable open (even though I only clicked it once), and none of them will close via task manager. I have to restart the PC in order to close them.

I am not getting any errors that I can see in the unity editor when I build it, and it plays perfectly in the editor.

I have tried building other projects to PC and they work fine. This is the only one causing me issues. I dont get the Unity splash screen, nor the resolution drop down menu. All that happens is an endless hourglass.

I am not sure what to do. If there is anyone that can help me, I would owe you enormously.

Something worked for me.
I created new clean project. There was no problem with building clean project.
I opened new project folder → ProjectSettings and copied two files:
EditorBuildSettings.asset
ProjectSettings.asset

I replaced in my old projects these two files with the files from clean project.

Of course the build/project settings will change (so it is obvious to backup), but at least the build is working.

Hope it will help you.
Regards.

I´m sorry i can´t help you. Im searching days now, for a solution solving this problem. I´d like to bump this question.

Regards

I have successfully built the game for Android, and web. The only one that will not work is PC.

Im considering trying to lower my .net framework API within unity, but I dont think thats the issue considering I can build other projects to PC just fine.