Gameobject gets inactivated


I’ve stumbled upon a very weird bug in my game.

When I click on my player (which is a sprite) through a UI element - it disables some other UI element.

I have no idea how that happens as it never should happen.
The object that’s getting disabled is not even referenced in code anywhere, I never try to disable it anywhere else or do anything with it.
How can this happen? How do I check what could be disabling it?

Any help will be very appreciated, this is really frustrating.
I’ve tried using a script to find any references of that object in every single script and it’s not referenced. I’ve also tried forcing it to just show, but it still dissapears and appears back in like .5s, so it’s a visible blink and I don’t want that in the final product. I’m out of ideas as this should really not happen and I don’t know where to begin checking what’s causing it.

Has anyone got an idea on how to go about fixing this or how to begin on testing what could be causing this?