Gameobjects are semi-transparent when I build the project for iOS

So I have a game which has some items and a player moving around the scene and 1 camera with player follow script.

Everything renders perfectly in the editor but when I build for iOS the player( and his trail) is visible even when he is behind some object, Weird.

I have tried to build via 2018.2 and 2018.3 but same results every time.

I am using a package from asset store with 3D models but I’ve changed all the materials’ shader to Standard with renderer mode set to Opaque, Fade, etc but nothing seems to work.

Never had this issue before so I have no idea how to fix. Everything is perfect in the Editor but only messes when I build for iOS.

Anyone with any solution? :frowning:

Quick workaround.

I just changed the Materials shader to Legacy diffuse & Transparency Sort Z axis.
[Unity 2018.3] Project settings > Graphics > Transparency Sort Axis Z ( from 1 to 0 )
And it worked.
I am not a shader expert so I don’t know what can be the issue.