GameObjects not showing up

GameObjects aren’t showing up in the Scene viewport. I don’t know what I’ve done please assist.

I Believe I Got Your Answer If Its Not Too Late.
(1) Maybe You Might Have Disabled Default In The Layers Dropbox. If You Did Then Check It Back And Focus Onto The Object. It Worked For Me.
I Had The Same Problem As You But I Noticed I Had To Check Default And Focus On It.

Locate the “Layers” dropdown menu button, on the upper right-hand corner of the Unity application and CLICK it…

77329-layersdropdownbutton.jpg

You will see a list of items: Everything, Nothing, Default, etc.

To the right of these listed items, you should see some “EYEcons” (sorry, I couldn’t resist) - CLICK the EYEcon next to the Everything item, and you should now be able to see EVERYTHING.

77330-layersdropdown.jpg

You can use this dropdown to make visible/invisible (or, technically, “show” or “hide”) things you want to see or do not want to see displayed in the Scene window.

also i noticed that if you have an animation and you create a duplicate and don’t change the position on the animation it will bring it to the default (prefab position) when u go on game mode! I was having issues but noticed this quick problem hopefully helps someone in the future!

just click on the cross (next to the hand) on the top left. Had the same problem…

o.k. if your gameobject is not showing up. select it in the object tab and then put your mouse over the 3d view and press “F” to focus on your gameobject.

Well I can focus on it and such, but it doesn’t actually show up, I just see the transition arrows to move it.

I have the same problem once when i am importing the project…because i have imported a 2D project and view it in perspective view it didn’t showing anything after changing it to 2D view it shows everything on scene view.

click on 2D next to the RGB shown in scene view…or see it from different view angle.

this is due to the selection of a Quad or plane. it is visible only from one side.

look at the drop bar layers at the top right hand side of the screen next to layouts and set every thing to visible (a little open eye). hope this helps it worked for me.

I had the same problem. Setting Z to 1 for position of GameObject solved the issue. For some reason, it wouldn’t render GameObjects which had Z value zero.

I got the the same problem, the solution of mine is on the layer. I have changed the layer From everthing seen to the UI seen. So everthing in the scene directly disappear. So i’m back to change the Layer to be Everthing. Just Share…

mine show fine in parallel projection view but don’t show in perspective projection

this didn’t help because in my case even though all my layers are visible I still can’t see. but when I set the invisible object to “default” it becomes visible… but in my editor I can’t change that for some reason even though I have set it up as default in its prefab.

if you’re spawing it from a prefab, make sure is not disabled. Or that is veeeeeery small

After upgrading to Unity 2018.3 I had some issues with graphics settings, but I figured out reading the unity blogs.

  1. If your camera in your scene has ‘Rendering path’ setting to default, it might not show some of your prefabs or instances. Try changing it to see the objects rendered on screen.
  2. It might be your graphics API selection on newer versions. Go to Project Settings → Player → other settings and uncheck Autographics to see what API you graphics unit might support. Just a play around is not enough. Read about it on the unity blogs before you choose API

if you’re developing for XBOX with Unity 2018-3, visit here.
https://blogs.unity3d.com/2018/12/2...6.1365772769.1546089470-1507696043.1524009639

i have a 2d game object that does not show up while im playing the game but it does in scene. i have already tried everything in the comments but it still dosent show up. what should i do?

The day is April 6th, 2021… and I ran into this issue and found the simple solution thanks to a link to this question post. :smiley: Turns out I did not have the layers set to default and that simple setting solved my issues. These questions and answers are awesome and good for a long time!