Getting Blacksmith Environment to work with Unity 2017

When I run the Blacksmith Environment in Unit 2017.2.0b11, I get an error about the obsolete WebPlayer.
I remove this line, then I start the scene.
What I’m getting is the attached screenshot.
I think there’s something substantially wrong.
Does anybody know how to get it to work normally?

I have this exact same result. Half hour of searching and your post is all I found.

+1 on this problem too. Took so long to download, import and regen lighting but still looks as in the OPs piccies. Seems like an issue with the AtmosBigBadSphere but I’ve fiddled with no success