Getting Deterministic compilation failed After Reinstalling unity and open old project.

Error :
Deterministic compilation failed. You can disable Deterministic builds in Player Settings
Library\PackageCache\com.unity.multiplayer-hlapi@1.0.4\Editor\Tools\Weaver\AssemblyInfo.cs(22,28): error CS8357: The specified version string contains wildcards, which are not compatible with determinism. Either remove wildcards from the version string, or disable determinism for this compilation

Go to Package Manager. Go to the small arrow right to to the + then select Packages: Unity Registry. In the list you should find Multiplayer HLAP and then click on the right side on Up to date.
I hope that helps.

I updated that “Multiplayer HLAP” - but my error stayed , then I removed the component and the error was gone

The solution worked for me. Thanks

@Dr_GeoFry I also got the
"I am getting “Microsoft (R) Visual C# Compiler version 3.5.0-dev-20359-01 (8da8ba0c) Copyright (C) Microsoft Corporation. All rights reserved.”
error after updating.

Here is how I solved it.
So I think the AssemblyInfo.cs file located in “\Library\PackageCache\com.unity.multiplayer-hlapi@1.0.4\Editor\Tools\Weaver\AssemblyInfo.cs” cannot be changed and the error you got happens when unity tires to update the AssemblyInfo.cs

I am assuming you are importing a Asset which has the pre-requisite “multiplayer-hlapi”.
So you first have to install the updated package from unity registry (say multiplayer-hlapi 1.0.8)
Then if you import your Asset THEN IT WILL WORK FINE.