Getting "Installation Aborted" when attempting to install Unity Hub

Hi, I just tried to install Unity Hub after uninstalling it(had some issues with it.), but now I can't install it.
It just says "Installation Aborted" "Setup was not completed successfully.". No errors or anything.
I'm running it as administrator, tried a different installation folder as well. Any ideas what could be wrong?
Didn't seem to find much about it on Google.

No logs is generated either.
Any ideas?

10 Likes

You can find the logs here:

  • Windows: %UserProfile%\AppData\Roaming\UnityHub\logs
  • Mac: ~/Library/Application support/UnityHub/logs
  • Linux: ~/.config/UnityHub/logs
3 Likes

Already checked, there is no logs. Atleast not from the installation. The log file's modification date doesn't match the time I tried to install. I also tried to remove the UnityHub folder and then try to install Unity Hub, but it didn't generate any logs.

Do you have enough disk space available?


Yes, I've got 244gb available :-)

2 Likes

I got it to work by downloading an older version of the Unity Hub, specifically v1.6.1 by using the Wayback Machine(thanks to a link in another thread).
It installed fine. Something’s probably wrong with the new Unity Hub installer.
And I successfully updated to the newest version 2.2.1 by updating through the old version of Unity Hub.

6 Likes

Can you please leave a link to the Thread. I have been having the same issue as you and not being able to find a solution. Also it appears that on installing the latest setup it says installation aborted. I dont know whether this is due to having changed the Owner in Advanced Settings of UnitySetup.exe. I am looking for a fix ;(
I cannot install the Hub.

1 Like

I got it working by removing all previously installed unity hub versions from Program and Features (in Windows)

7 Likes

Hi, I can’t remember what thread it was, but I managed to find the wayback machine link again:
https://web.archive.org/web/20190410133024/https://public-cdn.cloud.unity3d.com/hub/prod/UnityHubSetup.exe

I believe it is UnityHub v1.6.1 :slight_smile:

13 Likes

I was having the same issue, and then ran UnityHubSetup.exe as “Administrator,” and it worked.

This worked for me, thanks man…

1 Like

Okay, so I downloaded, ran as admin, and it installed. Once the hub installed, I tried to download the latest version of Unity. It would get all the way to “Installing…” then it wouldn’t complete. I have to extract certain files myself, and the package manager would refuse to work. Any help anyone?

2 Likes

Im having the same problem

@ITZZZETHAN @EthanHunterUnity

Hmm, did you update the UnityHub to the latest version via the UnityHub program itself, after installing the v1.6.1?
That is what I did and I didn’t have any issues after :slight_smile:
If you did do that however, I’m not sure what is causing it

1 Like

Same here…

@EthanHunterUnity @ITZZZETHAN

I was able to finally fix this trouble!
I fixed registry several times with usage of "CCleaner" and after it installation of UnityHub was successful

4 Likes

Hello I did use the website and it didn’t work I did download the last update 28/3/2020 and I didn’t find the log

I fixed it!
Just go to control panel > Programs and Features > find Unity hub (In my case it was still showing event after uninstallation), try to uninstall > one dialog would be popped up saying “we are unable to find this program, want to remove from the program and features list?” > click yes and DONE!

Basically unity Hub installer is looking for the already installed version of it in Programs and feature list, so even after uninstallation, if unity hub is still listed on that list, unity will abord the installation.

Hope, this will help.

58 Likes

Thank you pruthvipatel145 for helping me fix this problem I am sow excited to create games and again thank you

Awesome, glad you all got it fixed :-)