Getting Obsolete Error after Downloading Standard Assets Package


I am new to both Unity and Unity Answers. I am having trouble getting the Standard Assets package to work properly in Unity Version 2020.2. What I was trying to do was create a first person controller in one of my first projects by following the tutorial at the following YouTube Link:

I tried to follow what the tutorial was saying by deleting my Main Camera and utilizing the FPSController camera, but when I tried to test that camera, Unity was telling me to correct all errors before Play mode can be used. So I keep getting the following error below:

Assets/Standard Assets/Utility/SimpleActivatorMenu.cs(11,16): error CS0619: ‘GUIText’ is obsolete: ‘GUIText has been removed. Use UI.Text instead.’

The YouTube video at the link above gave watchers a heads up that we needed to download and patch the files for Unity versions 2019.4.1f or later, which is the case for me. Here is the exact advice of the video:

Download the fix files for 2019.4.1f1 or later.
GitHub - johnathanhales/UnityStandardAssetFixes: A fix for the "SimpleActivatorMenu.cs", "FPSCounter.cs" and "ForcedReset.cs" files that come with the Unity Standard Asset package..

Patch the 3 files in your project folder (Where you made the current project): ProjectYouCreated\Assets\Standard Assets\Utility

Can someone walk me through this? I am very new to Unity and I don’t know how to fix the error I’m getting above. Now I cant even test my project unless the error is resolved.

Thanks for the help.

Nevermind! I figured it out! I did what the YouTube video advised and downloaded the appropriate files to the appropriate Utility folder belonging to Standard Assets. The Files that needed to be updated for the package to work were the following:




Also, the FPSController works! Even if we keep the Main Camera GameObject in our Hierarchy!

Hope this helps those who experienced similar errors!