Getting some error always when I open Unity

Always when I open Unity I see this error: Assertion failed: Assertion failed on expression: ‘(srcData.GetChannelMask() & copyChannels) == copyChannels’
I can edit my scenes and everything, but it is annoying to see this always when I start Unity.

Apparently this is an issue with meshes without UV being set as lightmap static.

Simple fix: for every static object in your scene, uncheck “Lightmap Static”.

I had this same error. I had a static mesh without UVs in my scene. To fix it, I went to the import settings on that mesh and checked “Generate Lightmap UVs”.

Still no solution? I too get this error now after updating to 2018.1.0f2.

Same here:
I cant Build anymore on 2018.2
@jadapa did you found a solution?

Assertion failed on expression: '(srcInfo.GetChannelMask() & copyChannels) == copyChannels'

0x0000000141515C98 (Unity) StackWalker::GetCurrentCallstack

0x000000014151C1D6 (Unity) StackWalker::ShowCallstack

0x00000001413EC6BB (Unity) GetStacktrace

0x00000001408A0870 (Unity) DebugStringToFile

0x000000014085E88A (Unity) VertexUtility::CopyChannels

0x000000014080B4E4 (Unity) ExtractMeshComponentArray<Vector3f>

0x000000014083906C (Unity) CalculateNormalizedLightmapArea

0x0000000140829AB9 (Unity) MeshRenderer::GetCachedNormalizedLightmapArea

0x000000014112B115 (Unity) AddInstance

0x0000000141131B28 (Unity) ExtractGIInstances

0x0000000141146792 (Unity) GISceneManager::GetInstancesWithDuplicates

0x0000000141146257 (Unity) GISceneManager::GetInstances

0x000000014114B6CC (Unity) gi::UpdateMaterials

0x000000014114AD6E (Unity) GISceneManager::Update

0x0000000141144EB5 (Unity) `GISceneManager::GISceneManager'::`2'::tickGIInEditorRegistrator::Forward

0x0000000140628B89 (Unity) CallbackArray::Invoke

0x00000001414293DE (Unity) Application::TickTimer

0x000000014159377D (Unity) WindowsDropTargetImpl::DragEvent

0x0000000141593931 (Unity) WindowsDropTargetImpl::DragUpdated

0x00000001415938AC (Unity) CDropTarget::DragOver

0x00007FFB5BD6DC77 (ole32) RevokeActiveObjectExt

0x00007FFB5BD6DAB0 (ole32) RevokeActiveObjectExt

0x00007FFB5BD36E98 (ole32) OleGetPackageClipboardOwner

0x00007FFB5BD36E40 (ole32) OleGetPackageClipboardOwner

0x00007FFB5BD3A39F (ole32) DoDragDrop

0x000000014159E67C (Unity) DragAndDrop::StartDelayedDrag

0x000000014158D855 (Unity) DragAndDrop::ApplyQueuedStartDrag

0x00000001415ACC2C (Unity) GUIView::OnInputEvent

0x0000000141378CEC (Unity) GUIView::ProcessInputEvent

0x00000001415ADDB9 (Unity) GUIView::ProcessEventMessages

0x00000001415A7340 (Unity) GUIView::GUIViewWndProc
0x00007FFB5C76B85D (USER32) CallWindowProcW

0x00007FFB5C76B1EF (USER32) DispatchMessageW

0x00000001415C7E3E (Unity) MainMessageLoop

0x00000001415CA238 (Unity) WinMain

0x00000001423F90EA (Unity) __scrt_common_main_seh

0x00007FFB59F91FE4 (KERNEL32) BaseThreadInitThunk

0x00007FFB5C98EFC1 (ntdll) RtlUserThreadStart

Do check “Generate Lightmap UVs” as The Pilgrim mentioned but as i wanted lightmaps on my meshes i didnt want to uncheck the Lightmap static option on the mesh so i found that if you want the Lightmap static option, check the static option for the object itself (top right of the inspector beside its name), this clears the error for me.