Getting warning after importing plugin to unity5 project.

I am getting following warning when I import any plugin to my unity5 project.Whats the solution for this warning? Is there any problem with that which will affect my project.

41867-api.png

Its a Unity 4 plugin - in that it contains what is now considered to be ‘Legacy’ code.

Make a Backup!!!

Oh did I mention to make a backup?

The API updater will attempt to replace the obsolete code with the new API calls. It may fail.

Unity 5 is a Major release. Major Releases always contain Game Breaking changes. Upgrading to a Major release mid project is Definitely Not Advisable.