Google Play Console rejected cause of non-SDK API.

Hi there,

I just got rejected by some strange warning messages about unsupported API usage.
alt text

Sorry for hungarian, that’s my native.

So… after spending some days googling about this issue I found a thread which unity technologies told to keep posted, but forgot to do so for months. All i want to know is how can i avoid these things, make tests to see these warnings, or even how to fix them.
I use visual studio 2017 and unity 2019.2.0f1 currently.
thanks in advance.

Nova

Well i found a solution. may not work for everyone, but it done the magic for me.


In short: you need to update the android sdk manually.


step-by-step:
1, In unity preferences → external tools uncheck the “installed with unity”.
2, The default path will be shown. Go there, and open “bin” or “tools/bin” folder.
3, Open a console here (shift + right click)
4, type: " sdkmanager “platforms;android-25” " to download the API-s (this is for the level 25 API write this to needed one)
5, it will first prompt you a EULA or sth like that, hit y, and continue.
6, after you got all levels you needed type: “sdkmanager --update” to get the updates.
7, restart unity
8, look for space in your place for the bags of money you will earn with the game you made =)


Again: it worked for me, maybe it will solve your problem too, maybe not. Worth a try amirite’?


original thread: https://forum.unity.com/threads/google-play-api-warnings-started-today.676654/page-2