Google Play corrupts my game?

Hello, I’ve encountered an issue which I cannot solve.

Ive developed a small arcade game for android, the game worked perfectly fine in each build I tested and things were going great!

Ive uploaded it to google play store and redownloaded it from there, in my game I have a main menu, now in this very same build which I tested before uploading to google play the gui buttons worked well, I could load levels n other stuff like that and now 1 out of my 4 menu buttons work and thats the quit button.

Ive reuploaded a newer version, which I tested carefully with my phone before doing so and the newer version had the same issue!

Why the game gets fucked after being uploaded to google play?
And how can I solve this?

MANY MANY MANY THANKS for anyone who helps!

Fixed the issue!

In the ‘Player Settings’ menu I accidently checked the “Binary Split” option thingy.

Well, some games split their content in to packs for storage optimization.
so unity forms an obb spare file which is the expansion and the original APK file which I uploaded had only a part of the content, and the other obb file had the other part.

If you encounter that issue, simply uncheck the “Binary Split” button in the build player settings menu.

Hopefully no one would have such a stupid issue.