Google Play Games Sign-In not showing

I don’t know what I should try. I searched days to find a fix and nothing works. I just want to use Play Games Services in my game but not even the Sign-In Window is showing up.

Social.Active.localUser.Authenticate((bool success) => {
            if (success)
            {
                Debug.Log("Successful logged in.");
            }
            else
            {
                Debug.Log("Login failed.");
            }
        });

Yes i am using GooglePlayGames and UnityEngine.SocialPlatforms. I activate the Play-Games services with

PlayGamesPlatform.DebugLogEnabled = true;
PlayGamesPlatform.Activate();

I have the right App-Signing Code from the Upload-certificate and my app is already on Google Play for Alpha testing. I also added myself and another account as a Play Games tester so I could use the Services but that also does not work.

I don’t know that to do now and I am done with myself an I would be so infinitely grateful to every step that helps me. If you need some code you wanna take a look at, just write a comment.

For the one who need help, if nothing is pop up for you to sign in even loading green circle. You need to resolve dependencies. Go to Assets > Play Services Resolver > Android > Force Resolve inside Unity and then rebuild the apk. If this option is not there then install this plugin GitHub - googlesamples/unity-jar-resolver: Unity plugin which resolves Android & iOS dependencies and performs version management. Also for more info check these comments android - Latest Google Play Game Service Plugin For Unity Not Working - Stack Overflow

Hey. I’ve been struggling with this issue and finally found a solution (just incase anyone else comes here). First follow the guide: GitHub - playgameservices/play-games-plugin-for-unity: Google Play Games plugin for Unity


  1. SHA1. So if you navigate to App signing (currently under setup in the 2020 play console). You’ll find 2 SHA1 certificates. The upload certificate is for uploading your game to the store and should have the same SHA1 as the keystore you use to sign the game in unity. You can use keytool in a terminal window to check this.

Now go to the API console (https://console.developers.google.com/) select your project and go to credentials. Click on your project name under OAuth 2 Client IDs, and check the SHA1 certificate.
If you’re testing by downloading from Google Play it should be the same as the App Signing Certificate. If you’re testing by Uploading from unity directly to your phone it should be the same as the Upload Certificate.


  1. Force Resolving. So when I imported the Google Play Games package for some reason it left out the Force Resolver (you may see people telling you to force resolve). If this menu isn’t there for you (should be under Assets somewhere), manually reimport the package and look again (make sure that a folder called “external dependencies” is getting imported).

  1. Android SDK folders. You need to make sure you have the right folders in your SDK. The easiest way to do this is via SDK Manager/android studio. Here’s what I have in mine:

Android 5.1 to 10+ (I’ve been told that 6 is very necessary).


The following tools
168427-screenshot-2020-09-30-122428.png


And these

But the exact folders you need aren’t hard to find.

Good luck!

Did you find a solution? I’m in the same boat. Upload certificate is correct on API console, testers enabled, SDK is up to date. I’ve tried every tutorial I could find and started a new application/linked app for each one. None of them gets any results. No green window for signing on ever pops up. Let me know if you find anything.