Google Play no longer accepts app built in release mode

When I try to update my Unity app on the Google Play Store, I get this message: “You uploaded an APK or Android App Bundle that was signed in debug mode. You need to sign your APK or Android App Bundle in release mode.”

After reading some other answers I found that I should have created a new Keystore before publishing the app on the Play Store. But I didn’t do this (I apparently used the default Unsigned one), and yet the Play Store still accepted the five releases I’ve already published prior to this. Maybe this is because I have “App signing by Google Play” enabled?

I made sure that Development Mode is unchecked in the build settings. I tried switching to Release mode in Visual Studio and rebuilding – still get the same error message. I also tried creating a new custom keystore and building with that, but of course the Play Store complains that “You uploaded an APK that is not signed with the upload certificate.”

I’m not sure what I changed since the last time I successfully updated the same app a few weeks ago. I didn’t update Unity. Any ideas?

UPDATE: I downloaded an older APK from the artifact library and reuploaded it. I got the same error. So it seems like something has changed on Google Play rather than my build process.

I just uploaded my first one so I hope this helps. I went in to the project settings and filled out the keystore completely. When I did the build, I checked the bundle instead. It uploaded without fail. I hope that helps.