Google Play Services Authentication works only in Development Build?

I have the following flow in my Android game:
Start in ‘loader Scene’ → GPG Authentication → PlayFab Authentication with GPG Token → Load first ‘play’ scene.

When I build in Unity with the flag ‘development build’ set in the Build Settings Dialogue and run it on my phone, I get logged in fine and all works great. If I disable the flag and ‘Build & Run’ onto my Android phone, then it doesn’t log in. The game just hangs on the ‘loader Scene’ forever and since I don’t have logs, I don’t know exactly what went wrong.

This is even before uploading it to Google - so the signing certificate I use is still the same (no GoogleSigning happened yet to screw this up) and since it’s the same account and it worked on the dev version, I know my settings for the test account work also.

Has anybody else had a similiar issue?
Is there some config file somewhere that I am not aware of that changes Google settings for a development build?

Seems like my problem was unrelated to GPS in the end.

It turned out that my application had an exception because of a missing gameanalytics.jar that wasn’t properly built into the game. Fiddling with the build settings resolved this and now it works fine for me.

However if you come across an issue like this, you want to check if your Google Play Service is released already! According to some sources it may cause problems. It wasn’t for me in the beginning, so I did release it in the process. Now I cannot tell for sure if that was the issue. So please check that and maybe comment on this - for further generations - if it really is the release issue.