Google Play Services sign in not working well on Unity Android

I’m trying to add Google Play Services on my Unity Android project. I’ve got already implement google play services plugin to my project. Filling the all crediantials. I’ve got 2 different internal test accounts on developer console.

Here is my question:

  • Account A: SignInStatus Success and not showing welcome pop-up message

  • Account B: SignInStatus Canceled and not sign in.

Is it because internal test or something?

unity version: 2019.4.16f1
gpgs plugin verison: 0.11.01

Here is my code: referanced: GitHub - playgameservices/play-games-plugin-for-unity: Google Play Games plugin for Unity

using GooglePlayGames;
private bool Authenticated;

public void Start() {

internal void ProcessAuthentication(SignInStatus status) {
  if (status == SignInStatus.Success) {
    // Continue with Play Games Services
    Authenticated = true;
  } else {
    // Disable your integration with Play Games Services or show a login button
    // to ask users to sign-in. Clicking it should call
    // PlayGamesPlatform.Instance.ManuallyAuthenticate(ProcessAuthentication).
    Authenticated = false;

Saw this question on Stackoverflow as well, just wanna to confirm for anybody else facing the same issue that it’s gpgs plugin verison: 0.11.01 issue. You should use a previous version (10.14), it works well.

For account B issue, it’s probably because another phone (account) wasn’t added to a tester list. In Google play console in order to be able to test the GPGS, you have to add testers both into internal testing AND Gpgs testing (it’s separate).

Seeing same issues here. Triple checked the accounts unable to log in on Google Play console and should be working correctly but still not logging in. Is there anything else that could be tried?