Gradle errors with ARCore building to phone

I am new to trying mobile development and I’m having some errors I don’t know how to deal with when I build and run to my phone.

I’m using Unity 2019.4.19f1
I have added the packages ARFoundation and ARCore.
I am able to select my phone in the Build Settings.

The first error I get is “The Vulkan graphics API is enable. This is not supported by ARCore.” I am able to disable this. Will this cause more problems later on?

I can remove this: Edit>Project Settings>Player>Other Settings>Graphics APIs.

Trying to build again I get the following errors:
ARCore requires at least Gradle version 5.6.4 (5.1.1 detected)

I am able to select “Continue Anyway”. I then receive the following errors.
“Manifest merger failed with multiple errors”
“Configure Project: Launcher”
“Missing ‘package’ key element package at [arcore_client:] Android Manifest.xml”
"CommandInvokationFailure: Gradle build failed. "

I’ve looked at video tutorials to set up mobile development to my phone, and I haven’t seen anything like this. Do I upgrade Gradle? I’m not sure how I do this through Unity.

Any help would be appreciated.

I was able to get the latest Gradle from this link:
https://services.gradle.org/distributions/

And pointed to the location of the new Gradle Files in Preferences>External Tools.

I am still getting the following errors:

Configure project :launcher

Task :launcher:processReleaseManifest FAILED

Execution failed for task ‘:launcher:processReleaseManifest’.

CommandInvokationFailure: Gradle build failed.

Build completed with a result of ‘Failed’ in 219 seconds (219406 ms)
UnityEditor.BuildPlayerWindow:BuildPlayerAndRun()