Grainy look on model when given shadows

What would cause this grainy effect when I enable shadows, is there something wrong with the model itself? Any help would be appreciated

Move the bias slider on the light that your shadows are enabled on slightly above zero to solve this, i put mine on something like 0.08.

More help here: Unity - Manual: Lights