Grass (detail mesh) always has green/yellow tint, help!

Hello everyone,

I can’t for the life of me find out how to fix the coloration of my terrain grass detail mesh. It’s too green, so I’ve been solving that by altering the grass’ healthy and dry tints to being very red. Unfortunately, it seems that colors multiply toward a lower numerical color. This means that my red override makes the grass too dark.

Example of the default grass:

Example of color-altered grass:

Unfortunately I can’t upload more images, so I’ll have to describe my settings.

The above grass was altered by applying these settings:
Healthy Color:
R: 200
G: 128
B: 128
A: 255

Dry Color:
R: 128
G: 64
B: 64
A: 255

Grass Tint:
R: 255
G: 255
B: 255
A: 0

These are the troubleshooting steps I’ve taken so far. Again, I had more images to show, but you’ll have to take my word for it.

  1. I changed the healthy and dry colors to a very light gray.
  2. I kept the Grass Tint at 255,255,255,0.
  3. I altered the diffuse texture of the grass in Photoshop so that it was almost entirely white.

The result of these changes was that my grass now appeared EXTREMELY neon green and yellow. I’m searching throughout the detail mesh (technically a tree), the Optimized Leaf Material, and Terrain settings and I can’t find anything causing those neon greens and yellows. I need to wash those colors out in order to keep my grass light in color but not green.


Still having this error. As you can see, my detail meshes are completely grey. All components I can identify have been stripped of their color. Healthy and dry colors are set to grey. Wind > Grass Tint is set to grey.

And yet my grass is wildly green. I need to get rid of this green so I can match the grass to the trees and terrain.



i have send u a mail please check it and reply me