Grass Won't Show — Any Suggestions on the Cause?

[revised question]

I’ve encountered an issue where grass stops showing in Unity (in iOS builds and in the Editor in Mac/Windows/iOS platform modes). I’ve tried all the settings I know and haven’t found a solution. Also, I’m seeing large slow-down which did not occur before this issue began, which makes me think I’m encountering a Unity bug. However, if anyone has suggestions on what I might have missed I’d love to hear them before I file this as a bug with UT.

What Happened:

  1. I made a rough sample terrain using the built-in terrain system and coated the terrain in (fairly thick) grass. It worked fine for some time in Windows.
  2. I switched to MacOS and built for iOS, to find that the grass did not show on my iPad 3rd gen. Everything still appeared fine in the Editor.
  3. Upon closing and restarting Unity, the grass also stopped showing in the Editor.
  4. Now, I find that the grass won’t show in any platform setup, in WIndows or MacOS, and attempting to paint additional grass results in nothing.
  5. Additionally (possibly related) I’m experiencing slow-down in the Editor which wasn’t there before. The scene has not changed in complexity or content except for the missing grass.

Here is the scene in question, with a very roughed-out terrain. This terrain was previously coated in thick grass, but now nothing appears. Attempting to paint grass gives no results.


And here are the other terrain settings. Note that detail distance and density are at max to ensure grass isn’t culled.


Note: This question has been revised. The original question asked was, “Unity iOS support grass?”, motivated by my problem at point #2 above. I revised the post to reflect the further information I’ve gathered.

Definitely ‘works’ for iOS. It could be your code/materials/etc that is the problem.

Currently, what method are you using for this supposed ‘grass’ ?

Okay! Moments after totally revising the question above, I found the culprit: I had done lightmapping on the terrain prior to the issue occurring, and didn’t make the connection because the problem didn’t show in the Editor until Unity restarted. Clearing the lightmap has brought all my grass back.

Also, I reproduced this issue in another scene using mesh details (rather than billboard grass) and experienced massive slow-down as a result, culminating in an out-of-memory crash.

I’ll prep a bug report for UT and see if I can close this question.