Gravity Is Slow But Unit Scale Is 1.0


I have a unit of ~1 (I have it standing next to a new cube to verify this).

Its scale is set to 1,1,1

However when I add a rigidbody and collider to it (and the cube beside it) the cube will fall at a nice speed, but the character will fall VERY slowly.

Gravity is set to the standard 9.81.

Can you think of a reason why this character is falling very slow?

This is an imported model but I don’t see any other settings I can adjust in the inspector.

Dont put the rigidbody and animator on the same object. Put an empty parent object and put the rigid body on that. The model should be a child and not attached to a rigidbody.